
Photo Editing and Drawing in GIMP: 

An Introductory Lesson

This guide provides several hands-on exercises on photo editing and drawing in GIMP, with the
goal of making a beginner level introduction to using the software.

This lesson assumes that GIMP's user interface is in English.

Photo editing: touching up an old postcard photo

In the photo editing exercise, we'll try to improve an old postcard photo. In order to proceed, please
download  the  image  from  the  following  web  link:  https://ajapaik.ee/photo-
thumb/73108/800/jaapan-kobe-linna-koganji-templi-vaade/     ( ).

Open the image file in the GIMP: either choose File => Open and then choose the location of the
downloaded image; or, alternatively,  if  the image is on the desktop, you can drag-and-drop the
image to the grey area in the middle of the GIMP window in order to open it. As a result, you
should see a similar view:

GIMP's user interface. Drawing/editing area in the middle, tool docks in left and right

Adjusting color levels. The postcard in the image looks faded and grey – it could use a bit more
contrast  between colors.  Let's  try to  improve the situation.  Choose  from the  menu  Colors  =>
Levels. You should see a window Adjust Color Levels opening. The histogram in the window shows
the amount of pixels per each level of shades, starting from the black tone and ending at white tone.
In case of balanced color levels, pixels are distributed over all levels of the scale. But in our case,
most of the pixels are on the right side:

https://ajapaik.ee/photo-thumb/73108/800/jaapan-kobe-linna-koganji-templi-vaade/
https://ajapaik.ee/photo-thumb/73108/800/jaapan-kobe-linna-koganji-templi-vaade/
https://creativecommons.org/licenses/by-nc-sa/4.0/


This indicates that the light tones are overrepresented, and there is not enough information about the
darkest colors. In order to improve the balance, select the leftmost triangle (the black triangle) under
the histogram, and move it in the right direction: 

While moving the triangle, you should see how the contrast of the picture improves. If satisfied with
the result, press OK. The final result should look something like this:

Removing defects.  There are several ways for removing blemishes / defects / unwanted objects

from a photo. The first possibility is to use Color Picker  from the left side menu, pick a color

from the background next to the unwanted object, and use a Paintbrush Tool  with suitable size

and shape (brush) to cover the unwanted object with the background color. This works well enough
if the whole background of the unwanted object is in a single color. But in practice, a more typical
case is that the background is a pattern of different colors, and trying to imitate that with a single
color leaves an overall artificial impression of the fix.

An alternative is to use the Clone Tool  . This tool allows to select a small background area next
to the defect, create a brush from it and use it for covering the defect. Let's try this tehnique for
removing larger blemishes in the picture (blemishes in the sky above the temple roof):



Zooming. In order to get a closer view of a small area, you can use the  Zoom Tool  . After

picking the tool, right click in the middle of the area you wish to zoom in. And if you want to zoom
out, you can press either „-” button from the keyboard, or you can switch from „Zoom in” to „Zoom
out” in the left side „Tool options” and zoom out by right clicking on the area.

Next, pick the Clone Tool  from the left toolbox. From the Tool Options part of the left toolbox,
you can choose a suitable  Brush for the work – it is recommended to choose a paintbrush with
„soft / fuzzy contour”. And now the work can begin. Hold down CTRL, and choose an area next to
the defect for cloning (the clonable area will be within the brush contours). If you release CTRL,
two brush contours will appear: one stays fixed and marks the clonable area, and the other can be
moved  with  the  cursor  to  the  area  of  defect  and  can  be  used  for  covering  the  defect.  It  is
recommended to proceed in small steps: cover the defect step by step, try to choose clonable areas
from very close to the defect, and try to change the clonable area frequently. 

Use this tehnique for removing larger blemishes in the sky above the temple roof. If the work goes
fast,  you  can  also try to  remove blemishes  /  defects  from other  parts  of  the  picture.  But  it  is
sufficient, if you remove only defects in the sky above the temple roof. The final result could be
something similar:

Small fixes: getting the angle „right” and cropping. The postcard in the picture is a bit tilted. You

can confirm this if you choose the  Rectangle Select Tool  from the left toolbox, and make a

selection around postcard area: selection won't exactly match to borders of the postcard. 

Rotating the postcard. Choose Select => All (or press CTRL+A) in order to select the whole image.

Then choose The Rotate Tool   from the left side toolbox and click in the middle of the picture.

A window will appear, from where you can choose the angle of rotation, and the centre point. While
changing the angle, you should simultaneously see how the picture is rotated in the background. Try



to find the right angle. If you are done, press the button „Rotate” in the window. (Hint: the angle
-0.5 seemed to work rather well.)

After the rotation, a new layer called „Floating Selection” is created from the selection. This new
layer needs to be anchored to the picture before continuing the work. To do that, choose from the
menu Layer => Anchor Layer or press CTRL+H.

Croping the image. If you want to get rid of the grey border around the postcard, choose Rectangle

Select Tool  and make a selection that surrounds the postcard, but leaves out the grey border.

Then choose from the menu Image => Crop to Selection. The picture will be „resized” according to
the selection. After rotating and cropping, the picture should look similar to this:

Saving. In order to save the image, choose File => Save and choose a new location / name for the
image. This way the image will  be saved in the Gimp's native  XCF format,  and all  the image
manipulation information (selections, layers, channels etc.) will be saved alongside. If you want to
distribute the image, e.g. put it on the web, you should save it in a more common format, e.g. JPG
or PNG. This can be done by choosing from the menu File => Export.

Layers  and  selective  colorization. The  possibility  to  use  layers is  one  of  the  GIMP's  main
advantages compared to other, simpler photo management programs. Every picture in GIMP can be
made of multiple layers. These layers can be manipulated independently, and they can be merged
with each other, so that the whole visible picture is a result of combining multiple layers.

The list of layers, alongside with their thumbnails, can be seen on the right side toolbox, under the

tab . At the current time, there should be only one layer, which is named after the opened
file. You can change the layer (without affecting the file name), if you right click on the layer and
chose from the opening menu valida avanevast menüüst „Edit Layer Attributes”. Try it out: change
the layer's name to „Postcard”.

Next, we will try to change image in a way that most of it will turn to black and white, and only one
object in the picture will remain „colorful”. Make a copy from the existing layer: right click on the



layer's name and from the opening menu choose „New from Visible”. A new layer named „Visible”
is created on top of the existing layer, and the new layer copies everything that was seen on the
previous layer.

Change the new layer to black and white. For that, choose from the menu Colors => Desaturate.
Opens a window, where you can  „Choose shade of gray”. Try different variants – switching the
variants should immediately have an effect on the picture – and when the most suitable is found,
press OK.  The middle option should give the following result:

Although the picture is now black and white, the old colorful picture is not gone anywere – it is just
covered by the new layer. If you click on the eye figure  before the layer named „Visible” on the
right side „Layers” tab, then the black-and-white layer will be hidden:

and the underlying colorful layer will be visible once again. Try it out and then change the picture
back to black-and-white (by adding the  to black-and-white the layer).

Adding a mask to the black and white layer. Mask can be used turn parts of the layer transparent –
so  that  the  underlying  layer  will  appear.  White  mask will  be  fully  opaque (covers  entirely the
underlying layer), black mask will be fully transparent (the underlying layer will be entirely visible
through it) and a grey tone will make underlying layer partially visible through the upper layer.

Make a right click on the black-and-white layer (at the right side “Layers” list) and choose “Add
Layer  Mask”  from  the  opening  menu.  Opens  a  window,  from  which  you  can  choose  the
initialization value/color of the mask. Choose “White (full opacity)” – so that the created mask will



make the layer fully opaque / untransparent.  After creating the mask, a new thumbnail (a white
rectangle) will appear next to the “Visible” layer in the right side “Layers” list – this represents the
mask.

(!) Note that  the thumbnail of the active layer in the right side “Layers” list has a white border,
while thumbnails of the non-active layers have a black border. You can change the active layer by
clicking on the thumbnail. Tools only affect the active layer or mask, and not the inactive ones.

Drawing on the mask. When the mask is activated (thumbnail of the mask has a white border), then

painting an area in the picture with the black brush  will make the area transparent, and will

reveal the colorful layer under it.  Try it out.  Change one object in the picture – for instance, the
temple building  – „colorful”.  You should already have the black color as a foreground color by

default  (and if you have changed the color, then press   to reset the default colors). You may

want to change the size of the brush – using a big brush for covering large areas and a small brush
for tiny details.  If you have chosen the temple building for “coloring”, the final result should look
similar:

This ends the photo editing part of our tutorial. Parts of this tutorial were based on  Arvo Mägi’s
„GIMP 2.6.7 lühijuhend” (http://ubuntu.pingviin.org/gimp.pdf , in Estonian).

Drawing: illustrating an Estonian saying

In this part of the tutorial, we'll use GIMP for drawing.  The goal is to create an illustration of an
Estonian old saying „Egas kodu konn pole, et eest ära hüppab” (Home's no frog that it would jump
away from you; from this source).  The easy exercise would to be draw a small house, a bit more
complex one would be to draw a house and to add frogs legs / eyes to it – so that we would have a
weird figure, half a house and half a frog:

https://docs.google.com/document/d/15OydN7oEwJ9RKzerS3t-qrE_NV1WeWu5RT2OV5sU-pY/edit
http://ubuntu.pingviin.org/gimp.pdf


Create a new picture by choosing File => New.  Opens a dialogue window, from which you can
choose the image size. Choose the template 640x480 and press OK.

Use the Rectangle Select Tool  from the left side toolbox and create a rectangle selection to the

middle of the picture, with the height approximately 40 pixels and the width approximately 105
pixels. You can see the size of the current selection at the bottom border of the picture window.

Next, pick the bucket fill tool    and paint the rectangle to a grey-ish. You can change the color

with  the  button  “Background  &  Foreground  colors”  (the  upper  rectangle  is  the

foreground color used for painting, the lower color is the background color used for erasing). You

can also change the color in the right side toolbox – click on the tab “FG/BG color dialogue”  to

open the dialogue window.  From there you can also insert the color code, e.g. if you want to use
exactly the same color as I did for painting, copy the  c2b7a4 into the color entry textbox in the

“FG/BG color dialogue”:   .

Using the Paths Tool. Choose the Paths Tool  from the right side toolbox and then click on the

upper right corner of the grey rectangle.  A circle-shaped anchor point  will appear.  If you now
click on some other location in the picture, another anchor point will be created and two points will
be connected with a straight line.  The next click on the picture, and the third anchor point will
appear, and a line connecting the second and the third point. And so forth. Try to use this tool for
creating the roof of the house, which is approximately as high as the grey rectangle, but notable
wider from the bottom side (a trapezoid shape):

Closing the shape. If you have reached with the path to the upper left corner of the grey rectangle,
hold down CTRL and click on the first anchor point (in the upper right corner of the grey rectangle)
– this will close the shape.

Adjusting the path / figure. One of the advantages of using the Paths Tool is that the drawn path can
be modified / adjusted on the progress.  If you click on some anchor point,  then it will become
active  and  you  can  change  its  location  by  dragging  it  around. As  you  move  the  point,  lines
associated with the point will also move along.  Try it out: click on the first anchor point (in the
upper right corner of the rectangle), and drag it downwards. Then click on the point in the upper left
corner of the grey rectangle, and drag that also downwards, approximately to the same level as the



previous point:

You can also modify the lines between the points, for instance, making them curved instead of
straight. Do to this, click on the line between two points and drag it in the direction where you want

to make a curve. Both anchor points will also expose handles ,  which can be dragged to direct
the creation of the curvature.  Try to bend the right hip of the roof in a way that it will be curved
from outside to inside:

And do the same also with the left hip of the root. If you are ready, click on the button “Selection
from Path” on the left side toolbox (under “Tool options”). The roof figure should now appear as a
selection (surrounded by “running ants”):

(!) When using the Paths Tool, it is important to keep in mind that when the shape/figure is ready,
and you wish to use some other tool, you should always press the button “Selection from Path” in



order to preserve the selection. If you forget it, then selecting a new tool will erase the path and you
have to start all over again with the drawing shape/figure.

Now you can choose the  Bucket Fill Tool  and paint the roof area.  I used an orange-ish tone

with the HTML code c27b00, but you can choose any tone you like.

Using the same techniques (  +  or  + ), add a door, a window and a chimney to the

picture. Rectangle can be used to make orderly shapes, while the Paths Tool allows to experiment
with  more  interesting  irregular  shapes.  My  result  was  the  following  (colors:  door  –  7b4e00,
chimney – ac3f00 and window - white):

We are done with the house exercise now. If you wish to continue drawing, you can try to add frog’s
legs and eyes to the picture; if you wish to finish the drawing, you can go to the last page, and make
the one last step to complete the picture: add a text to it.

Frog’s legs. Choose the Paths Tool  and click on the lower left corner of the house. Then make

an angled line by creating another anchor point left, and a bit up, from the house. Like this:

Close the shape (hold down CTRL and click to the first anchor point). And then adjust the lines in a
way that both  lines will be curved outside:



Click on the button “Selection from Path” on the left side toolbox (under “Tool options”). And then

use the bucket fill tool  to paint the shape green (or any color you like; my color was: 7b9300).

Next, use the Paths Tool  for drawing frog’s flipper, like that:

´

You can draw a pretty rough shape at the first, then close it, and then try to adjust the shape by
moving the anchor points.  If you are done (satisfied with the shape),  then press  “Selection from

Path” on the left, and paint the flipper to green .

Now, try also to create the front leg / flipper using the paths tool   :



If you are done, then click “Selection from Path” on the left, and then paint the leg to green . If

both left side flippers are ready, use the free selection tool  and make a selection that includes

both flippers / legs, but leaves out the house. For example:

Next, make a copy of the chosen shape (CTRL+C or choose  Edit => Copy from the menu)  and

paste it to the screen (CTRL+V or Edit => Paste). In the right side „Layers dialogue”( ) a
new layer (Floating Selection)  will appear. This also means that the active layer is the „floating”
copy (you can move it around or draw on it), and you cannot change the other parts of the picture
while the copy is active.

Mirroring a shape. Choose the flip tool  from the left side toolbox, verify that the type of the

flip is „horizontal” (under the left  “tool options”) and then click one the copy of frog’s legs.  This
will reverse the pair of legs, so that we now also have a pair of legs for the right side. Next, choose

the move tool  , click on the legs and drag these to the right corner of the house:

Now, we have to attach the right side legs  (which is still a  Floating Selection!) to the underlying

picture. Do to this, navigate to the „Layers dialogue” (  ) on the right side toolbox, make a



right click on the “Floating Selection”  and from the opening menu, choose  “Anchor Layer”.

Eyes and eyebrows. As the previous to last step, you can add eyes and eyebrows to the figure. Use

the ellipse select tool  and make a circle-shaped selection on the top of the roof:

Then use the bucket fill  and paint it to white. Make a white circle also to the left side of the

roof (either by copying the white one, or by using + ). 

Next, make smaller black circles inside white circles (pupils):

And use the Paths Tool   to add a trapezoid shaped eyebrows:

 

After adding the eyebrows, the final picture should look similar to this:



Adding Text. As a last step, you can use the  Text Tool  and add the text of the saying to the

picture. Select the tool and make a rectangular selection – this will be the text area. Then click on
the rectangular selection and insert or copy the text. You can change font of the text on the left side
toolbox  (by clicking the  “Aa”  button);  there you can also change the color, size, alignment (and
various other parameters) of the text. I chose Bradley Hand ITC as the font, and „centered” as the
alignment, and got the following result:

Links : tutorials and guides

A more advanced drawing exercise: 

https://www.gimp.org/tutorials/Draw_A_Paint_Brush/

Gimp User Manual 2.8: 

http://docs.gimp.org/2.8/en/index.html

Online Book “Grokking the GIMP”: 

http://gimp-savvy.com/BOOK/index.html

An online source of GIMP's tutorials:

http://gimp-tutorials.net/

Links : art created with GIMP

A magazine for artwork created with GIMP: 

http://gimpmagazine.org

A gallery: artwork made with GIMP + the package Gimp Paint Studio:

 https://code.google.com/archive/p/gps-gimp-paint-studio/wikis/Gallery.wiki

https://code.google.com/archive/p/gps-gimp-paint-studio/wikis/Gallery.wiki
http://gimpmagazine.org/
http://gimp-tutorials.net/
http://gimp-savvy.com/BOOK/index.html
http://docs.gimp.org/2.8/en/index.html
https://www.gimp.org/tutorials/Draw_A_Paint_Brush/
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